B2B API Services status page
Incidents

Sage Invoice API Down

MAJORaffectedSAGElasted29min 33s

The incident has been resolved

resolved
Jan 17 17:43:04 (UTC)

Sage Invoice API Down

investigating
Jan 17 17:13:31 (UTC)
Powered by Checkly