B2B API Services status page
Incidents

API referential.location.v3 Down

CRITICALaffectedB2B API Criticallasted21min 32s

The incident has been resolved

resolved
Jan 24 22:09:23 (UTC)

Service is experiencing issue

investigating
Jan 24 21:47:50 (UTC)
Powered by Checkly