B2B API Services status page
Incidents

B2B Portal Down - Connected - Europe

MAJORaffectedB2B Portallasted15min 41s

The incident has been resolved

resolved
Jan 25 05:48:53 (UTC)

B2B Portal Down - Connected - Europe

investigating
Jan 25 05:33:12 (UTC)
Powered by Checkly