B2B API Services status page
Incidents

Sage Invoice API Down

MAJORaffectedSAGElasted13min 24s

The incident has been resolved

resolved
Jan 19 11:28:05 (UTC)

Sage Invoice API Down

investigating
Jan 19 11:14:40 (UTC)
Powered by Checkly